Apr 272013
 

Es gibt einige Anleitungen im Netz wo sich zu diesem Thema geäussert wird. Aber eine kurze Anleitung und die auch noch noch funktioniert ist mir auf die schnelle leider keine unter gekommen.
Nun stelle ich mal meine Notizen dazu Online und hoffe das auch andere damit was anfangen können..
Der Grund für diese Authentifizierung war ein Single-Sign-On für unseren zentralen SysLog-Server. Dort wurde eine Weboberfläche (Loganalyzer: http://loganalyzer.adiscon.com) installiert und wir möchten natürlich nicht das dort jeder Zugriff hat. Auch der Loganalyzer besitzt auch eine LDAP-Authentifizierung, die ich aber erst später funktionstüchtig auf Gruppenbasis ans laufen gekommen habe. Dazu schreibe ich später einen separaten Beitrag.

Als erstes sollte man die Vorbereitungen auf dem AD-Controller durchführen. Dazu habe ich eine extra Sicherheitsgruppe unter der OU „Groups“ erstellt (in diesem Beispiel nenne ich sie „AccessGroup“).
Anschließend weisse ich die entsprechenden Benutzer dieser Gruppe zu.
Weiter geht es mit einem extra Benutzer der nur für die LDAP-Anbindung genutzt wird (nehmt bitte keinen Amdinistrator).

Jetzt können wir das Modul für den Apache installieren

Nun muss das Modul noch aktiviert werden und der Apache einmal durchgestartet werden

Als letztes braucht man nur noch in der Apache Konfiguration die entsprechende Authentifizierung aktivieren

Bei uns liegen alle Benutzer in einer OU und nicht mehr unter „Users“. Deswegen erscheint auch hier die OU „Abteilung“. Jetzt noch einmal einen Restart des Apache Webservers durchführen.
Nun sollte das Verzeichnis durch eine LDAP-Authentifizierung geschützt sein. Funktioniert die Anmeldung nicht dann erhöht einfach den LogLevel in der Apache Konfiguration:

Jetzt sieht man genau wo das Problem besteht.

Feb 192013
 

Seit längerem habe ich einen Debian-Mirror für Wheezy erweitert. apt-mirror hat auch alles ordentlich heruntergeladen und es ist auch möglich, intern einen Server über den Mirror zu installieren. Mein Problem waren immer die Translations „i18n“, die nicht sauber von apt-mirror geladen wurden.
Nun bin ich über einen Beitrag gestolpert der genau dieses Problem fixt: Follow me

Man muss also nur die Datei „/usr/bin/apt-mirror“ mit einem Editor öffnen und nach der Zeile „363“ (Squueze) oder Zeile „355“ (Wheezy) (der Block sieht wie folgt aus):

und die nächsten Zeilen dort einfügen:

 

Anschließend startet man noch einmal „apt-mirror“ auf der Konsole und die Server die diesen Mirror als Quelle nutzen, bekommen nun auch Ihre i18n….

Durch das Fortsetzen der Benutzung dieser Seite, stimmst du der Benutzung von Cookies zu. Weitere Informationen

Die Cookie-Einstellungen auf dieser Website sind auf "Cookies zulassen", um Ihnen das beste Surferlebnis möglich zu geben. Wenn Sie diese Website ohne Änderung Ihrer Cookie-Einstellungen zu verwenden fortzufahren, oder klicken Sie auf "Akzeptieren" unten, dann erklären Sie sich mit diesen.

Schließen